Cobalt Technology - Holliday Tower Down – Incident details

Wichita Falls (Stadium Tower) under maintenance

Holliday Tower Down

Resolved
Major outage
Started 8 days agoLasted about 7 hours

Affected

Holliday Tower

Major outage from 1:45 PM to 8:43 PM

Updates
  • Resolved
    Resolved

    Utility power has been restored and the site is fully operational.

  • Monitoring
    Monitoring

    Backup power has been restored. Waiting for utility power to restore.

  • Identified
    Identified

    Utility power is down and backup systems have failed. We are working to resolve this as quickly as possible.

  • Investigating
    Investigating
    We are currently investigating this incident.